In R6RS and therefore in our current module system, you can't import the same name from two different places. I think we should consider changing this so that you can (import (foo)) and then (import (override)), where (override) contains a subset of the names defined in (foo). Otherwise you have to say (import (except (foo) this that). This is no doubt safer, but also more annoying.
There are two sub-issues: allowing this at the REPL and/or allowing it in modules.