The definitions of and and or may be slightly confusing. Reword them to be more clear. One possible hiccup is that the current language permits the return of different false values, while a clearer wording may preclude this.
R6RS provides a clearer definition that does not provide wiggle room for multiple false values. Should we use that?
I've already provided new wording. Please slow down and see what I've been doing.
We voted for the R6RS wording.
I prefer the R6RS wording.