In CondExpandCowan, the test for the existence/importability of a module is to specify the module name. However, this means module names can't begin with and, or, or not. Draft 3 instead specifies (module module-name), and I think this is better.
Now of course this is (library library-name).
The draft already specifies this, and there is currently
no non-ambiguous alternative proposed, so closing the
Reopening this, because even if there is no other proposal that resolves the ambiguity, it can be resolved by removing the feature. I want the feature, but the WG has to vote it in if we are to have it.
I'm not sure why there is an ambiguity here. Unless a library name is automatically considered a <feature identifier>, which doesn't appear to be true, then library must be wrapped around a library name in order to use it in a cond-expand clause.
John, when you say "I want the feature," which feature do you want? The ability to specify a library directly as a <feature identifier>, or just the ability to specify a library through a library clause?
So the choice for this ticket is between the last two.
The WG voted to adopt this proposal.